Главная Обратная связь

Дисциплины:






Использование логических функций.



Функция ЕСЛИ– используется при проверке условий для значений и формул.

ЕСЛИ(Условие;Выражение1;Выражение2)

Условие— это любое значение или выражение, принимающее значения ИСТИНА или ЛОЖЬ.

Например, в данной таблице:

  А В С
-8

если в ячейке A1 находится положительное значение, то Условие: A1>0— это выражение принимает значение ИСТИНА. В противном случае— ЛОЖЬ.

 

Выражение1— это значение, которое возвращается, если Условие равно ИСТИНА т.е. выполняется.

Выражение2— это значение, которое возвращается, если Условие равно ЛОЖЬ т.е. не выполняется.

В данном примере, значение ячейки А1 равно 10, это число положительное. Формула: =ЕСЛИ(А1>0;”Положительный”;”Отрицательный”)

возвращает строку Положительный.

Если бы в ячейке А1 находилось бы отрицательное значение, то заданная формула вернула бы значение Отрицательный.

Формула: =ЕСЛИ(В2>0;”Положительный”;”Отрицательный”)

возвращает строку Отрицательный.

Значения:Условие, Выражение1, Выражение2могут быть заданы формулами. Например: =ЕСЛИ(А1*В2>=0;В2^2;A1^2)

Если произведение А1 на В2 больше либо равно нулю, то вычислить квадрат значения ячейки В2, иначе возвести в квадрат значение ячейки А1.

Формула:= ЕСЛИ(A3=100;СУММ(B1:С3);"")

Если значение ячейки A3 равно 100, то имеет значение ИСТИНА и вычисляется сумма для ячеек B1:С3. В противном случае Условие имеет значение ЛОЖЬ и возвращается пустой текст (""), очищающий ячейку, которая содержит функцию ЕСЛИ.

Предположим, что рабочий лист по расходам содержит в ячейках B2:B4 фактические расходы за январь, февраль, март: 1500, 500 и 500 соответственно. Ячейки C2:C4 содержат данные по предполагаемым расходам за те же периоды: 900, 900 и 925.

Можно написать формулу для проверки соответствия бюджету расходов определенного месяца, генерируя тексты сообщений с помощью следующих формул:

=ЕСЛИ(B2>C2;"Превышение бюджета";"OK") равняется "Превышение бюджета"

=ЕСЛИ(B3>C3;"Превышение бюджета";"OK") равняется "OK"

Функция И. – возвращает логические значения ИТИНА или ЛОЖЬ в зависимости от логического значения своих аргументов. Если все аргументы принимают значение Истина, то функция И возвращает значение истина. Если хотя бы один из аргументов функции принимает ложное значение, то функция И возвращает значение ЛОЖЬ.

И(логическое_значение1;логическое_значение2;...)

Примеры: =И(А1<0; А2<0; А3<0)

Данная формула возвращает значение ИСТИНА, если все ячейки диапазона А1:А3 содержат отрицательные числа.



=ЕСЛИ(И(А1<0; А2<0; А3<0);”Все отрицательные”;”Не все отрицательные”)

В приведенном выше примере функция И используется в качестве первого аргумента функции ЕСЛИ. Если значения всех трех ячеек А1:А3 отрицательные, то формула выводит на экран строку “Все отрицательные”. Но если хотя бы одно из значений больше либо равно нулю, то формула возвращает строку ”Не все отрицательные”.

Функция ИЛИ– подобна функции И, с той лишь разницей, что функция ИЛИ возвращает значение ИСТИНА, если хотя бы один из аргументов истинный. В противном случае эта функция возвращает значение ЛОЖЬ.

Рассмотрим пример: Необходимо вывести текстовый комментарий к среднему баллу студента. Если средний балл больше 4,7, то диплом «красный», если нет, «синий». Средний балл студента вычислен в ячейке D3, комментарий к оценке поместить в ячейку Е3.

Технология ввода функции:

1. Установить курсор в ячейку Е3;

2. – На ПИ Стандартная кнопку

Или – Выполнить: – Вставка\Функция…

3. Выбрать категорию Логические и функцию ЕСЛИ Рис. 14;

 

Появится диалоговое окно аргументов функции Рис 15.

 

Рис. 14.

 

 

4. В окне Аргументы функции ввести последовательность аргументов;

(Список аргументов представлен на рисунке 15). Нажать кнопку ОК.

По мере ввода аргументов в предназначенные для них строки, строка ввода заполняется так, как если бы мы вводили данные с клавиатуры.

Кнопка позволяет увеличить масштаб строки ввода аргумента, а кнопка обеспечивает возврат в диалоговое окно на строку ввода.

Диалоговое окно аргументов функции.

 

Рис. 15.

 

По мере ввода аргументов в предназначенные для них строки, строка ввода заполняется так, как если бы мы вводили данные с клавиатуры.





sdamzavas.net - 2019 год. Все права принадлежат их авторам! В случае нарушение авторского права, обращайтесь по форме обратной связи...